Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

500 Response while uploading test application to the cloud

Dmitry May 25, 2016 03:37PM CEST

I'm getting 500 response while trying to upload test application via Testroid API (using spec http://docs.testdroid.com/testdroid-cloud-integration/api/examples/#testdroid-cloud-api-clients)

I tried both library testdroid-api v2.9 and my own client and I can't upload file:

com.testdroid.api.APIException: 500 Internal Server Error
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiExceptionMessage xmlns:ns2="com.testdroid.api" xmlns:ns3="cloud.testdroid.api.model.jrjc"><message>Internal Server Error</message><statusCode>500</statusCode></apiExceptionMessage>

I checked both POST /api/v2/me/projects/{projectId}/files/application and POST /api/me/projects/{projectId}/files/application and it still the same.

Can you check it on your side?
Do I need paid account to use cloud API?

Regards, Dmitry

Up 0 rated Down
Lasse May 25, 2016 04:17PM CEST Bitbar Testing help Agent
Hi,

Could you confirm that you have used an activated Testdroid account and existing project's ID from that account in your upload API call?
Up 0 rated Down
Dmitry May 25, 2016 05:38PM CEST
Hi Lasse,

I'm using free account (I assume activated, because I'm able to run project with free device - please confirm) and existing project. I upload application via UI multiple times without any problems.
Initially I thought that problem is in /api/v2/, that why I coded my own client to use just api/me/projects/{projectId}/files/application, but just the same result.

Via API I was able to authenticate and get project by id, but when I'm trying to upload application file I got 500 response.



Up 0 rated Down
Kaj Päivärinta May 26, 2016 12:40PM CEST Bitbar Testing help Agent
Hi,

This is the curl to upload your application
curl -F file=@'sample.apk' -u '<apiKey>:' https://cloud.testdroid.com/api/v2/me/projects/<projectID>/files/application

This is to way to validate it was successful
curl -u '<apiKey>:' https://cloud.testdroid.com/api/v2/me/projects/<projectID>/files

---Kaj

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Contact Us

support@bitbar.com
http://assets0.desk.com/
false
bitbar
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete